logo

PNG用の公式ライブラリ「libpng」にバッファオーバーフローの脆弱性

  • このエントリーをはてなブックマークに追加

 独立行政法人 情報処理推進機構セキュリティセンター(IPA/ISEC)および一般社団法人 JPCERT コーディネーションセンター(JPCERT/CC)は7月6日、PNG Development Groupが提供しているPNG用の公式ライブラリ「libpng」にバッファオーバーフローの脆弱性が存在すると「Japan Vulnerability Notes(JVN)」で発表した。

 この問題が悪用されると、細工されたPNGファイルを読み込んだ場合にバッファオーバーフローが引き起こされ、ユーザー権限でリモートからコードを実行される可能性がある。本脆弱性の影響を受けるシステムは、「libpng 1.4.3より前のバージョン」「libpng 1.2.44より前のバージョン」「libpng 1.0.x」となっている。

 なお、PNG Development Groupではこの脆弱性を解消する最新版を公開しており、該当するユーザーは最新版にアップデートするよう呼びかけている。

-PR-企画特集