logo

CMS「XOOPS Cube Legacy」にクロスサイトスクリプティングの脆弱性

  • このエントリーをはてなブックマークに追加

 独立行政法人 情報処理推進機構セキュリティセンター(IPA/ISEC)および有限責任中間法人JPCERTコーディネーションセンター(JPCERT/CC)は4月2日、XOOPS Cube Projectが提供する「XOOPS Cube Legacy」にクロスサイトスクリプティング(XSS)の脆弱性が存在すると公表した。

 XOOPS Cube Legacyは、オープンソースのコンテンツ管理システム(CMS)。今回確認された脆弱性は、XOOPS Cube Legacy 2.1.6 およびそれ以前のバージョンに存在する。この脆弱性が悪用されると、悪意ある利用者が細工したページをユーザーが読み込んだ場合、ユーザーのブラウザ上で任意のスクリプトを実行される可能性がある。

 XOOPS Cube Projectでは、この脆弱性を解消する新バージョンやパッチを公開しており、最新版へバージョンアップするよう呼びかけている。なお、開発者によるとXOOPS Cube Legacyのディストリビューション「ホダ塾ディストリビューション」や「追加モジュール」は、この脆弱性の影響を受けない。

 JVNではこの脆弱性の危険度について、以下のように分析している。

  • 攻撃経路;インターネット経由からの攻撃が可能(高)
  • 認証レベル:匿名もしくは認証なしで攻撃が可能(高)
  • 攻撃成立に必要なユーザーの関与:リンクをクリックしたり、ファイルを閲覧するなどのユーザー動作で攻撃される(中)
  • 攻撃の難易度:専門的知識や運がなくとも攻撃可能(高)

-PR-企画特集